User Tools

Site Tools


openwrt:structure_pre_1.0

Result of Problem determination should look like (<1.0)

mount
root@piratebox:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14752k)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda1 on /mnt/usb type vfat (rw,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /mnt/ext type ext3 (rw,sync,relatime,user_xattr,barrier=1,nodelalloc,data=ordered)
/dev/loop1 on /opt/piratebox type ext3 (rw,sync,relatime,user_xattr,barrier=1,nodelalloc,data=ordered)
ls -la /mnt/
drwxr-xr-x    1 root     root             0 Jan  1  1970 .
drwxr-xr-x    1 root     root             0 Jan  1 00:11 ..
drwxr-xr-x    5 root     root          1024 Jan  1  1970 ext
drwxrwxrwx    3 root     root          4096 Jan  1 00:00 usb
ls -la /mnt/usb
root@piratebox:~#  ls -la /mnt/usb
drwxrwxrwx    3 root     root          4096 Jan  1 00:00 .
drwxr-xr-x    1 root     root             0 Jan  1 00:49 ..
drwxrwxrwx    5 root     root          4096 Jan  1  1980 PirateBox
-rwxrwxrwx    1 root     root        142205 Jun 17  2012 piratebox_ws_img.tar.gz
ls -la /mnt/usb/PirateBox
root@piratebox:~# ls -la /mnt/usb/PirateBox
drwxrwxrwx    5 root     root          4096 Jan  1  1980 .
drwxrwxrwx    3 root     root          4096 Jan  1 00:00 ..
-rwxrwxrwx    1 root     root      67108864 Jan  1 00:01 OpenWRT.img
-rwxrwxrwx    1 root     root      33554432 May 19  2012 OpenWRT.swap
drwxrwxrwx    2 root     root          4096 Jan  1  1980 Shared
drwxrwxrwx    2 root     root          4096 May 19  2012 board
-rwxrwxrwx    1 root     root          1799 Jan  1  1980 index.html
-rwxrwxrwx    1 root     root      20971520 Jan  1 00:38 pbIMG_ws.img
drwxrwxrwx    2 root     root          4096 May 19  2012 tmp
ls -la /opt/piratebox
root@piratebox:~#  ls -la /opt/piratebox
drwxr-xr-x    9 root     root          1024 Jan  1 00:03 .
drwxr-xr-x    4 root     root             0 Jan  1  1970 ..
drwxr-xr-x    2 root     root          1024 Jun 17  2012 bin
drwxr-xr-x    3 root     root          1024 Jan  1 00:03 conf
drwxr-xr-x    2 root     root          1024 Jun 17  2012 init.d
drwx------    2 root     root         12288 Jan  2  1970 lost+found
lrwxrwxrwx    1 root     root            18 Jan  1 00:03 share -> /mnt/usb/PirateBox
drwxr-xr-x    2 root     root          1024 Jun 17  2012 src
drwxr-xr-x    2 nobody   nogroup       1024 Jan  1 00:00 tmp
-rw-r--r--    1 root     root            19 Jun 17  2012 version
drwxr-xr-x    5 nobody   nogroup       1024 Jan  1 00:04 www
ls -la /opt/piratebox/www
root@piratebox:~# ls -la /opt/piratebox/www
drwxr-xr-x    5 nobody   nogroup       1024 Jan  1 00:04 .
drwxr-xr-x    9 root     root          1024 Jan  1 00:03 ..
-rwxr-xr-x    1 nobody   nogroup       1458 Jun 17  2012 .READ.ME.htm
lrwxrwxrwx    1 root     root            27 Jan  1 00:03 Shared -> /opt/piratebox/share/Shared
lrwxrwxrwx    1 root     root            26 Jan  1 00:03 board -> /opt/piratebox/share/board
drwxr-xr-x    2 nobody   nogroup       1024 Jun 17  2012 cgi-bin
-rwxr-xr-x    1 nobody   nogroup       1518 Jun 17  2012 chat.html
-rwxr-xr-x    1 nobody   nogroup       1406 Jun 17  2012 favicon.ico
-rwxr-xr-x    1 nobody   nogroup        172 Jun 17  2012 forum.html
-rw-r--r--    1 nobody   nogroup       1799 Jun 17  2012 index.html
-rw-r--r--    1 nobody   nogroup      94840 Jun 17  2012 jquery.min.js
drwxr-xr-x    3 nobody   nogroup       1024 Jun 17  2012 library
-rwxr-xr-x    1 nobody   nogroup      12637 Jun 17  2012 piratebox-logo-small.png
-rwxr-xr-x    1 nobody   nogroup      16453 Jun 17  2012 piratebox-logo.png
-rwxr-xr-x    1 nobody   nogroup        148 Jun 17  2012 redirect.html
-rwxr-xr-x    1 nobody   nogroup        298 Jun 17  2012 style.css
drwxr-xr-x    2 nobody   nogroup       1024 Jun 17  2012 success
cat /opt/piratebox/version
root@piratebox:~#  cat /opt/piratebox/version
piratebox-ws_0.2.1
cat /etc/config/network
root@piratebox:~# cat /etc/config/network
 
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

(This may differ depeding which hardware you use- but 'lan' section should have this IP.)

cat /etc/config/wireless
root@piratebox:~# cat /etc/config/wireless
 
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr 'f8:d1:11:a9:xx:xx'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
 
config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'PirateBox - Share Freely'
        option encryption none

(This may differ depeding which hardware you use.)

FIXME cat /etc/openwrt_release

FIXME cat /etc/pbx_custom_image

dmesg | tail -n 20 no useful example possible.

ps
root@piratebox:~# ps
  PID USER       VSZ STAT COMMAND
    1 root      1500 S    init
    2 root         0 SW   [kthreadd]
    3 root         0 SW   [ksoftirqd/0]
    5 root         0 SW   [kworker/u:0]
    6 root         0 SW<  [khelper]
    7 root         0 SW   [kworker/u:1]
   48 root         0 SW   [sync_supers]
   50 root         0 SW   [bdi-default]
   52 root         0 SW<  [kblockd]
   80 root         0 DW   [kswapd0]
  129 root         0 SW   [fsnotify_mark]
  142 root         0 SW<  [ath79-spi]
  154 root         0 SW   [mtdblock0]
  159 root         0 SW   [mtdblock1]
  164 root         0 SW   [mtdblock2]
  169 root         0 SW   [mtdblock3]
  174 root         0 SW   [mtdblock4]
  179 root         0 SW   [mtdblock5]
  219 root         0 SW   [kworker/0:1]
  406 root         0 SWN  [jffs2_gcd_mtd3]
  431 root         0 SW   [khubd]
  442 root         0 SW   [scsi_eh_0]
  443 root         0 DW   [usb-storage]
  467 root      1500 S    init
  499 root         0 SW<  [cfg80211]
  581 root         0 SW<  [bat_events]
  616 root      1504 S    /sbin/syslogd -C16
  618 root      1484 S    /sbin/klogd
  620 root       860 S    /sbin/hotplug2 --override --persistent --set-rules-f
 1403 root      1496 S    /sbin/watchdog -t 5 /dev/watchdog
 1521 root      1508 S    /usr/sbin/crond -c /etc/crontabs -l 5
 1531 root      1152 S    /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
 1621 root         0 SW   [flush-8:0]
 1623 root         0 SW   [flush-7:1]
 1684 root      1496 S    /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.ope
 2279 root      1356 S    hostapd -P /var/run/wifi-phy0.pid -B /var/run/hostap
 2657 root      1216 S    /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
 2658 root      1504 S    -ash
 2670 root         0 SW   [kworker/0:2]
 2682 root         0 SW   [kworker/0:0]
 2705 root       860 S    /sbin/hotplug2 --override --persistent --set-rules-f
 2714 root         0 SW   [flush-7:0]
 2744 root         0 DW<  [loop0]
 2746 root         0 SW   [jbd2/loop0-8]
 2747 root         0 SW<  [ext4-dio-unwrit]
 2770 root         0 SW<  [loop1]
 2773 root         0 SW   [jbd2/loop1-8]
 2774 root         0 SW<  [ext4-dio-unwrit]
 2788 nobody     936 S    /usr/sbin/dnsmasq -x /var/run/piratebox_dnsmasq.pid
 2797 root      7028 R    python /opt/piratebox/bin/droopy -H piratebox.lan -d
 2812 nobody    3512 S    /usr/sbin/lighttpd -f /opt/piratebox/conf/lighttpd/l
 2813 root         0 Z    [sh]
 2815 root      1492 R    ps

Important processes are:

  • /usr/sbin/dnsmasq -x /var/run/piratebox_dnsmasq.pid
  • python /opt/piratebox/bin/droopy -H piratebox.lan -d
  • /usr/sbin/lighttpd -f /opt/piratebox/conf/lighttpd/l
  • hostapd -P /var/run/wifi-phy0.pid -B /var/run/hostap
openwrt/structure_pre_1.0.txt · Last modified: 2013/11/01 17:44 by matthias