User Tools

Site Tools


modifications:scriptbased_04

Modifications for Scriptbased Piratebox

Fits to Version 0.4

Change SSID

OpenWRT

You can change the SSID with editing the file /etc/config/wireless and then

/etc/init.d/network reload

your Network settings to make the change active.

Debian

Edit the file /opt/piratebox/conf/hostapd.conf and change the line

ssid=piratebox: free share

and restart your PirateBox-Scripts

Change of IP-Adresses

Changing the IP-Adress is a bit more complicated thing. You have to exchange the IP in the following files:

  • /opt/piratebox/conf/hosts
  • /opt/piratebox/conf/piratebox.conf - The following lines:
  IP=192.168.77.1
  #Config for dhcp  ( should be in the same range like defined ip)
  IPSTART=192.168.77.10
  IPEND=192.168.77.120
  • Additional on OpenWRT you need to change /etc/config/network
 config interface 'loopback'                                                               
      option ifname 'lo'                                                                
      option proto 'static'                                                             
      option ipaddr '127.0.0.1'                                                         
      option netmask '255.0.0.0'                                                        
                                                                                        
 config interface 'lan'                                                                    
      option ifname 'eth0'                                                              
      option type 'bridge'                                                              
      option proto 'static'      
 #------  CHANGE THE LINE BELOW -------
      option ipaddr '192.168.1.1'          
 #------  CHANGE THE LINE ABOVE -------        
      option netmask '255.255.255.0'                                                    

Restart your Scripts and reload your network-config on OpenWRT:

 /etc/init.d/network reload 

Small python Forum

This feature is included in PirateBoxScripts >v0.4 & PirateBoxScripts_Webserver > v0.2

For installing the pyForum named Forest, run:

/opt/piratebox/bin/install_piratebox.sh /opt/piratebox/conf/piratebox.conf pyForum

Files for the forum are stored in /opt/piratebox/forumspace (which should be Backuped before upgrading).

On scriptbased PirateBox you have to do the following additional steps:

  1. Edit /opt/piratebox/conf/piratebox.conf find the line starting with FORUM_LINK_HTML and uncomment the 2nd line.
  2. Restart the PirateBox

Disabling Shoutbox

For Disabling the Shoutbox, you can have to find the following line in /opt/piratebox/conf/piratebox.conf

 #Chatbox 
 #  Change the not commented line to en- and disable Chat
 # CHAT_BOX_HTML=""
 CHAT_BOX_HTML="<iframe height='400px' width='50%' frameBorder='0' scrolling='0'  src='http://$HOST:8002'></iframe>"
 

With this, the box is still running in background, but won't show up anymore.

Secured directories

With secured directories it is possible to save folder with passwords or simply upload into a folder structure. To enable this feature, find the following lines in /opt/piratebox/conf/piratebox.conf

## Droopy Userdir Option?
DROOPY_USERDIR=""
# Uncomment the following line to enable Userdirs
#DROOPY_USERDIR="-u True"

Remove the # in the last line and restart your PirateBox-Scripts.

Exchange Upload-Folder

Do you want, that your users uploads to a different directory than the default directory, where the “Browse” link points to? You can easily achieve this with editing /opt/piratebox/conf/piratebox.conf. Find this line and enter your new upload folder:

#Upload Folder
# Change this if you want to user uploaded data in a subfolder
#   Make sure the folder exists
# UPLOADFOLDER="$FOLDER/Upload"
UPLOADFOLDER=$FOLDER

Avoid special characters in directory-name and ensure the directory exists and has the correct permissions!

Disabling Shoutbox-Reset after reboot

This feature is included in PirateBoxScripts >=v0.4.1 & PirateBoxScripts_Webserver > v0.2.

On default, the Shoutbox is cleared on a new startup. To disable this, you need to set the following line in /opt/piratebox/conf/piratebox.conf to no

 # Reset Shoutbox on Startup?
 RESET_CHAT="yes"

How-To Customize your PirateBox

Beside changing the SSID of your box, your can do the following stuff can be changed to exchange the look of your box:

Landing Page Text

Find this line in /opt/piratebox/conf/piratebox.conf

 #Text on droopy 
 TEXT="<b>1.</b> Learn more about the project <a href=\"http://$HOST:8001/.READ.ME.htm\" target=\"_parent\"><b>here</b></a>.<p><b>2.</b> Click button below to begin sharing.</p><b>3.</b> Browse and download files <a href=\"http://$HOST:8001\" target=\"_parent\"><b>here</b></a>.<br>"

Pictures

Pictures on the landing-page are located in the folder /opt/piratebox/src. You can simply exchange the files (same name) or add new files. With last, you have to refer to the new files in /opt/piratebox/conf/piratebox.conf

 #Image-SRC
 IMAGENAME="piratebox-logo-small.png"
 IMAGE="/opt/piratebox/src/$IMAGENAME"

The same pictures are located on your Share-Folder. You need to remove/exchange them to.

ReadME File

The Readme linked on Frontpage is located in /opt/piratebox/src and will be copied over to your share folder. You need to remove or change them after install.

Hostname

1. Edit /opt/piratebox/conf/piratebox.conf find this line:

 #HOSTNAME  ... if you really want to change it, plz change:
 #    bin/droopy
 #    conf/hosts
 HOST="piratebox.lan"

2. Add the new name in /opt/piratebox/conf/hosts

 192.168.1.1  piratebox.lan 
 192.168.1.1  piratebox
modifications/scriptbased_04.txt · Last modified: 2014/04/14 19:20 by matthias